<<  2008.3  >>
SMTWTFS
      1
2345678
9101112131415
16171819202122
23242526272829
3031     
 
リンク
その他
  • RSS2.0
  • Credit

  • SEO
    loading

    プライバシーポリシー

カテゴリー » Linux » いろいろ March 10, 2008

kernel 2.6.24 で VMware Server 1.04 Linux

Player(Workstation)と同じく、ホストOSを2.6.24にするとServerも使えなくなる。
# vmware-config.pl
/tmp/vmware-config0/vmmon-only/./include/vm_basic_types.h:159: error: redefinition of typedef 'uintp
include/linux/types.h:40: error: previous declaration of 'uintptr_t' was here
/tmp/vmware-config0/vmmon-only/./include/compat_wait.h:37:5: 警告: "VMW_HAVE_EPOLL" は定義されていませんmake[1]: *** [_module_/tmp/vmware-config0/vmmon-only] エラー 2
Unable to build the vmhgfs module.
Execution aborted.
有り難いことに
VMware Server v1.04 On Fedora 8 With Kernel 2.6.24[HowtoForge]
で修正パッチを作ってくれてます。
# wget http://downloads.howtoforge.com/vmware_server_on_f8_2.6.24/vmware.tar.bz2
# tar xvfj vmware.tar.bz2
# cd vmware/
# \cp vm* /usr/lib/vmware/modules/source/
# vmware-config.pl
Fedora8以外でも使えると思う。たぶん。

ゲストOSとした場合のVMware-Toolsは open-vm-tools を利用すればOK

≪追記 2008/03/16≫
1.0.5(build-80187)が公開されるも上記の問題は修正されず。
11:42 pm | コメントする |

累計:18034、今日:260、昨日:466
Created in 0.0101 sec.